The Vicious Linux Wireless Circle

Posted on 12 May 2009 in Computers (4 comments)

I feel like I'm stuck in a vicious circle.

I recently broke the USB wireless dongle I use on my eight year old Linux running laptop PC. Without it, the laptop can't connect to the internet. Hmm.

So I pop out and buy a new wireless dongle. I did my research - it's a Belkin and is well supported on Linux. Result.

I plug it in and lo... nothing happens.

Turns out that particular driver doesn't work with the version of Ubuntu I'm running on the laptop (namely XUbuntu 8.04). The cure is to re-install the drivers. Which may work. Or may not. But then the drivers don't seem to be online anywhere. All the links to them are broken.

So the solution is to upgrade to a later version of XUbuntu. Fine. Except that there's a reason I never upgraded XUbuntu on that laptop. It's because in XUbuntu 8.10 and onwards, there's a problem with the video driver and things don't work properly. Bits of the screen don't update properly - they render in the wrong colour, or just randomly disappear.

That's not an isolated incident. I saw exactly the same problems when I tried Vector Linux this time last year. I suspect it's a problem with the graphics drivers hence may appear on many versions of Linux. There are some known issues with recent Intel drivers although whether they're the same ones I'm seeing is another matter.

Now I know what you Linux experts will say next. Use the Vesa drivers! The old never fail graphics standby.

Which screw up the graphics completely, go all multi-coloured and very swirly. It's very psychedelic but absolutely no use for checking my email.

So I'm in a complete viscous circle. I can't use the wireless dongle unless I upgrade. But if I upgrade I can't use the PC properly because the graphics driver doesn't work.

It's one of those lovely situations where you're sure there's a solution, but you're completely stumped as to how to solve it. Bar buy a new PC. Or a homeplug...

< previous | top ^ | next >

Share this page on

Your Comments

Paul said:

You may have meant to use the word 'viscious', but I rather enjoy the concept of a viscous circle. Seems the more appropriate choice for linux problems on older computers. With every attempt to move forward, the annoying small problems just bog you down. Eventually, you can't move at all! I just did an Ubuntu upgrade ... took over 4 hours to get the display working correctly again.

Posted on 13 May 2009 at 3:53 AM

Andrew Bowden said:

In my defence it was getting past my bed time and my brain wasn't working so I relied on the old spell checker. Then picked the wrong result!

Whoops!

No more viscous circles for this blog post!

Before I went to bed I did spot this post about new drivers which may solve the Intel driver issues.

Downside is to test them I'm probably going to have to install XUbuntu 9.04 on my laptop rather than run it as a live CD.

Thankfully my main PC upgraded to Ubuntu 9.04 (I only use XUbuntu on the laptop) without hitch.

Posted on 13 May 2009 at 9:32 AM

Alan in Belfast said:

Alternatively use a USB-powered wifi receiver/adapter/access point that plugs into your laptop via the LAN port.

I successfully used the ASUS WL-330 for an old laptop that didn't have USB2 so might have struggled with a proper USB wifi dongle.

It's a little bit less neat than a USB dongle, but it can't fail to work! (And it comes with a short RJ45 cable.)

Posted on 18 May 2009 at 6:18 PM

Andrew Bowden said:

It crossed my mind just to try and find a replica of my original USB dongle on ebay and do it that way! At least I'd know it works...

I'll follow this post up at some point, but it seems some distros like my laptop more than others. Both XUbuntu and Ubuntu 9.04 have the graphics problems, but a Debian live CD and some others had no problems with the display. I have probably spent more money on blank CD-Rs (the laptop can't boot off CD-RWs) than I would have just to buy an extra dongle!

My new plan is to get a copy of Debian Live with Xfce and see if that works. Now to find the time...

Posted on 19 May 2009 at 11:44 AM

Have your say

Sorry but comments on this post are closed, but you can still email me.

Cookies Policy | Contact Us